Installare Compact Framework 2.0

mercoledì 13 aprile 2011 - 22.19
Tag Elenco Tags  C#  |  Visual Studio 2005

paolo973 Profilo | Senior Member

Ciao a tutti,

ho un dispositivo con win ce 5.0.
Sul mio computer fisso ho installato Visual Studio 2005.
Ho creato un progetto per smart device win ce 5.0.
è solo un banale esempio con un textbox ed un button.

il dispositivo con win ce è attaccato via usb al fisso.

da vs 2005 avvio il tasto F5.

alla fine ottengo sul dispositivo con win ce 5.0 una scritta che mi dice di installare un
compact framework più nuovo.

Come installare un Compact Framework sul dispositivo con win ce 5.0?
l'ho scaricato è un file NETCFSetupv2.msi
come eseguirlo ? dove copiarlo precisamente ?

freeteo Profilo | Guru

Ciao,
se non ricordo male, quel pacchetto si installa sul tuo pc e poi va a fare il deploy dentro al device tramite usb, un po' come fa Visual studio (che dovrebbe scaricare nel tuo disco quel pacchetto durante l'installazione di vs stesso).

Ricordo che io avevo in passato recuperato il file del framework che invece deve essere eseguito sul device, ed è un .cab (guarda sotto a C:\Program Files (x86)\Microsoft.NET\SDK\CompactFramework\v2.0\WindowsCE), ed andavo tramite "WceLoad" a lanciarlo sul device fisico, evitando quindi di doverlo attaccare tramite usb.

Ti lascio un link da cui prendere qualche info per come fare il deploy di un'applicazione mobile:
http://msdn.microsoft.com/en-us/library/aa446503.aspx
http://msdn.microsoft.com/en-us/library/ms933760.aspx


Ciao.

Matteo Raumer
[MCAD .net, MVP Visual C#]
http://blogs.dotnethell.it/freeteo

paolo973 Profilo | Senior Member

Grazie Freeteo.

freeteo Profilo | Guru

>Grazie Freeteo.
di nulla figurati, siamo qui per questo.

Ma hai risolto? Casomai posta la soluzione del tuo problema se l'hai trovata, anche a grandi linee, così può tornare utile a chi si trovasse a passare per questo thread...

Ciao.

Matteo Raumer
[MCAD .net, MVP Visual C#]
http://blogs.dotnethell.it/freeteo

paolo973 Profilo | Senior Member

l'errore era provocato dal CF 2.0.

è stato necessario installare il 3.5
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2017
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5