NET Framework 2.0. Messaggio di errore: urgente

mercoledì 23 febbraio 2011 - 09.54

Carmelo1965 Profilo | Junior Member

Ciao a tutti, dovrei vedere un programmino che ho salvato da casa, l'ho pubblicato, ovviamente a casa
funziona. Con il mio computer dell'ufficio mi chiede di installare ovviamente .NET Framework 2.0 , quando si installa mi segnala il seguente errore:

Impossibile installare i seguenti componenti:
- .NET Framework 2.0
Per ulteriori informazioni, vedere il file di log dell'installazione in 'C:\DOCUME~1\carmelov\IMPOST~1\Temp\VSD1DF.tmp\install.log'.

qualcono può aiutarmi.....

grazie mille Carmelo


Ciao, ringrazio tutti per la vostra pazienza...

alx_81 Profilo | Guru

>Ciao a tutti
Ciao

>Per ulteriori informazioni, vedere il file di log dell'installazione
>in 'C:\DOCUME~1\carmelov\IMPOST~1\Temp\VSD1DF.tmp\install.log'.
>qualcono può aiutarmi.....
sei andato a vedere quel file? Cosa trovi scritto?

>grazie mille Carmelo
di nulla!
--
Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.support.microsoft.com/profile/Alessandro.Alpi

Carmelo1965 Profilo | Junior Member

Ciao Alessandro, grazie per la risposta veloce, nella cartella c:\DOCUME~1\carmelov\IMPOST~1\Temp\VSD1DF.tmp\install.log'. ho un setup.exe che sembra quello avviato da me ed un tx installa.log
nella cartella sottostante che si chiama dotnetf ho i seguenti file : dotnetf.exe e langpack.exe, dato che il computer è dell'ufficio prima di lanciara una installazione che mi sputtana tutto vorrei chiederti cosa fare. Graizie mille.


Ciao, ringrazio tutti per la vostra pazienza...

alx_81 Profilo | Guru

>Ciao Alessandro, grazie per la risposta veloce, nella cartella
>c:\DOCUME~1\carmelov\IMPOST~1\Temp\VSD1DF.tmp\install.log'. ho
>un setup.exe che sembra quello avviato da me ed un tx installa.log
>nella cartella sottostante che si chiama dotnetf ho i seguenti
>file : dotnetf.exe e langpack.exe, dato che il computer è dell'ufficio
>prima di lanciara una installazione che mi sputtana tutto vorrei
>chiederti cosa fare.
Ripeto, leggi il log file e guarda cosa ti dice. La ragione del fallimento dell'installazione è scritta lì.
--
Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.support.microsoft.com/profile/Alessandro.Alpi

Carmelo1965 Profilo | Junior Member

ti mando il file allegato fammi sapere io non capisco nulla :
The following properties have been set:
Property: [AdminUser] = true {boolean}
Property: [ProcessorArchitecture] = Intel {string}
Property: [VersionNT] = 5.1.3 {version}
Running checks for package '.NET Framework 2.0', phase BuildList
Running external check with command line "C:\DOCUME~1\carmelov\IMPOST~1\Temp\VSD1DF.tmp\dotnetfx\dotnetchk.exe" -lcid:1040
Process exited with code 1
Setting value '1 {int}' for property 'DotNetInstalled'
Reading value 'Version' of registry key 'HKLM\Software\Microsoft\Internet Explorer'
Read string value '7.0.5730.13'
Setting value '7.0.5730.13 {string}' for property 'IEVersion'
The following properties have been set for package '.NET Framework 2.0':
Property: [DotNetInstalled] = 1 {int}
Property: [IEVersion] = 7.0.5730.13 {string}
Running checks for command 'dotnetfx\instmsia.exe'
Result of running operator 'ValueExists' on property 'VersionNT': true
Result of checks for command 'dotnetfx\instmsia.exe' is 'Bypass'
Running checks for command 'dotnetfx\WindowsInstaller-KB893803-v2-x86.exe'
Result of running operator 'ValueExists' on property 'Version9x': false
Result of running operator 'VersionLessThan' on property 'VersionNT' and value '5.0.3': false
Result of running operator 'VersionGreaterThanOrEqualTo' on property 'VersionMsi' and value '3.0': true
Result of checks for command 'dotnetfx\WindowsInstaller-KB893803-v2-x86.exe' is 'Bypass'
Running checks for command 'dotnetfx\dotnetfx.exe'
Result of running operator 'ValueNotEqualTo' on property 'DotNetInstalled' and value '0': true
Result of checks for command 'dotnetfx\dotnetfx.exe' is 'Bypass'
Running checks for command 'dotnetfx\langpack.exe'
Result of running operator 'ValueEqualTo' on property 'DotNetInstalled' and value '2': false
Result of running operator 'ValueEqualTo' on property 'AdminUser' and value 'false': false
Skipping FailIf because Property 'Version9X' was not defined
Result of running operator 'ValueNotExists' on property 'IEVersion': false
Result of running operator 'VersionLessThan' on property 'IEVersion' and value '5.01': false
Result of running operator 'VersionLessThan' on property 'VersionNT' and value '5.00': false
Result of running operator 'ValueNotEqualTo' on property 'ProcessorArchitecture' and value 'Intel': false
Result of checks for command 'dotnetfx\langpack.exe' is 'Install'
'.NET Framework 2.0' RunCheck result: Install Needed
EULA for components '.NET Framework 2.0' was accepted.
Copying files to temporary directory "C:\DOCUME~1\carmelov\IMPOST~1\Temp\VSD1DF.tmp\"
Downloading files to "C:\DOCUME~1\carmelov\IMPOST~1\Temp\VSD1DF.tmp\"
(23/02/2011 10.11.05) Downloading 'dotnetfx\langpack.exe' from 'http://go.microsoft.com/fwlink/?LinkId=37283&clcid=0x410' to 'C:\DOCUME~1\carmelov\IMPOST~1\Temp\VSD1DF.tmp\'
Download completed at 23/02/2011 10.11.07
Verifying file integrity of C:\DOCUME~1\carmelov\IMPOST~1\Temp\VSD1DF.tmp\dotnetfx\langpack.exe
WinVerifyTrust returned 0
File trusted
Running checks for package '.NET Framework 2.0', phase BeforePackage
Running external check with command line "C:\DOCUME~1\carmelov\IMPOST~1\Temp\VSD1DF.tmp\dotnetfx\dotnetchk.exe" -lcid:1040
Process exited with code 1
Setting value '1 {int}' for property 'DotNetInstalled'
Reading value 'Version' of registry key 'HKLM\Software\Microsoft\Internet Explorer'
Read string value '7.0.5730.13'
Setting value '7.0.5730.13 {string}' for property 'IEVersion'
The following properties have been set for package '.NET Framework 2.0':
Property: [DotNetInstalled] = 1 {int}
Property: [IEVersion] = 7.0.5730.13 {string}
Running checks for command 'dotnetfx\langpack.exe'
Result of running operator 'ValueEqualTo' on property 'DotNetInstalled' and value '2': false
Result of running operator 'ValueEqualTo' on property 'AdminUser' and value 'false': false
Skipping FailIf because Property 'Version9X' was not defined
Result of running operator 'ValueNotExists' on property 'IEVersion': false
Result of running operator 'VersionLessThan' on property 'IEVersion' and value '5.01': false
Result of running operator 'VersionLessThan' on property 'VersionNT' and value '5.00': false
Result of running operator 'ValueNotEqualTo' on property 'ProcessorArchitecture' and value 'Intel': false
Result of checks for command 'dotnetfx\langpack.exe' is 'Install'
'.NET Framework 2.0' RunCheck result: Install Needed
Verifying file integrity of C:\DOCUME~1\carmelov\IMPOST~1\Temp\VSD1DF.tmp\dotnetfx\langpack.exe
WinVerifyTrust returned 0
File trusted
Installing using command line '"C:\DOCUME~1\carmelov\IMPOST~1\Temp\VSD1DF.tmp\dotnetfx\langpack.exe" /q:a /c:"install /l /q"'
Process exited with code 1603
Status of package '.NET Framework 2.0' after install is 'InstallFailed'

Ciao, ringrazio tutti per la vostra pazienza...

ma_di Profilo | Junior Member

Ciao.
Hai verificato che la tua utenza sia amministratore di macchina?

Carmelo1965 Profilo | Junior Member

Hai ragione mi sa che il problema è quella dell'utenza, provo a chiedere informazioni al nostro Responsabile dell'area informatica. Grazie mille sei sempre molto gentile.
Ciao, ringrazio tutti per la vostra pazienza...

alx_81 Profilo | Guru

>Hai ragione mi sa che il problema è quella dell'utenza, provo
>a chiedere informazioni al nostro Responsabile dell'area informatica.
se hai win7 o vista puoi provare ad installare premendo tasto destro sull'installer e "Run as administrator" o "Esegui come amministratore".
potrebbe bastare se già sei admin della macchina..


--
Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.support.microsoft.com/profile/Alessandro.Alpi

Carmelo1965 Profilo | Junior Member

Ciao Alex, pur troppo ho windows xp ho l'impressione che è questione di adminstator. Funziona con Windows xp le indicazioni che mi hai dato con il tasto destro ??
Ciao, ringrazio tutti per la vostra pazienza...

Carmelo1965 Profilo | Junior Member

Ciao ho parlato ora con l'amm.re delle reti e ha detto che sono già come amministratore infatti ho guardato in opzioni contatto ed ha ragione, ho rinstalatto tutto come hai detto te mettendo la mia password, si installa e poi mi esce il seguente errore di prima
Impossibile installare il componente .NET Framework 2.0. Messaggio di errore:
'Errore irreversibile durante l'installazione. '
Impossibile installare i seguenti componenti:
- .NET Framework 2.0
Per ulteriori informazioni, vedere il file di log dell'installazione in 'C:\DOCUME~1\carmelov\IMPOST~1\Temp\VSD1FB.tmp\install.log'.

Potrebbe essere il fatto che abbia exprorer 7.0 senza alcun SP1 ECT. a casa ho EXPLORER 6.0 SP2 e funziona benissimo
Ciao, ringrazio tutti per la vostra pazienza...

alx_81 Profilo | Guru

>Per ulteriori informazioni, vedere il file di log dell'installazione
>in 'C:\DOCUME~1\carmelov\IMPOST~1\Temp\VSD1FB.tmp\install.log'.
questo log è identico all'altro come errore?
--
Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.support.microsoft.com/profile/Alessandro.Alpi

Carmelo1965 Profilo | Junior Member

Ciao è sceso il tecnico ha fatto l'installazione con la password da adminstrator anche se non serviva, in quanto ha detto che ho previlegi di installare tutto. Ha detto che era inutile installare il FRAMEWORK 2.0 dato che ho intallato la versione 5.0 , tuttavia non mi installa il programma per vedere il progetto che ho fatto da casa con Visual Studio 2005. A questo punto non so cosa sia. Ho anche installato il Framewor
SP2 - Secondo te cosa potrebbe essere, a casa mi funziona benissimo. Forse ho sabagliato la progedura della pubblicazione ???
Ciao, ringrazio tutti per la vostra pazienza...

alx_81 Profilo | Guru

>Ciao è sceso il tecnico ha fatto l'installazione con la password
>da adminstrator anche se non serviva, in quanto ha detto che
>ho previlegi di installare tutto. Ha detto che era inutile installare
>il FRAMEWORK 2.0 dato che ho intallato la versione 5.0
ehm? siamo arrivati al 4.. oppure la 5 di cosa?

>non mi installa il programma per vedere il progetto che ho fatto
>da casa con Visual Studio 2005. A questo punto non so cosa sia.
>Ho anche installato il Framewor
>SP2 - Secondo te cosa potrebbe essere, a casa mi funziona benissimo.
riesci ad aprirlo con visual studio almeno? Riesci a compilarlo?

>Forse ho sabagliato la progedura della pubblicazione ???
Che operazioni hai fatto di preciso?
--
Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.support.microsoft.com/profile/Alessandro.Alpi

Carmelo1965 Profilo | Junior Member

Ciao Ale, sono andato in proprietà del form, progettazione, e poi ho avviato semplicemente la pubblicazione, ovviamente ho indicato in quale cartella installarla. Forse avrei dovuto fare altro...


Ciao, ringrazio tutti per la vostra pazienza...

alx_81 Profilo | Guru

>Ciao Ale, sono andato in proprietà del form, progettazione, e
>poi ho avviato semplicemente la pubblicazione, ovviamente ho
>indicato in quale cartella installarla. Forse avrei dovuto fare
>altro...
si tratta di un'applicazione windows forms? Hai fatto il setup project? Altrimenti basta copiare la cartella bin/debug o quella che hai impostato te in debug o in release per eseguire il programma..
--
Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.support.microsoft.com/profile/Alessandro.Alpi

Carmelo1965 Profilo | Junior Member

infatti è proprio quello che mi blocca il setup.exe la cartella bin la devo travare in ufficio oppure stai dicendo di rifare tutto da casa...
Ciao, ringrazio tutti per la vostra pazienza...

Carmelo1965 Profilo | Junior Member

ti allego il mio progetto tanto è piccolo è solo una prova

Dato che ci sei mi fai un favore, se riuscirai ad aprire il piccolo progetto, noterai che quando
fai il Link sul link del datadrid si apre sempre il primo record, sapresti dirmi come risovere il problema, come noterai quando faccio la ricerca normale in automatico apro il record che desidero.
Con il Link non mi funziona...
Ciao, ringrazio tutti per la vostra pazienza...

alx_81 Profilo | Guru

>ti allego il mio progetto tanto è piccolo è solo una prova
>Ciao, ringrazio tutti per la vostra pazienza...
c'è solo il log..
--
Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.support.microsoft.com/profile/Alessandro.Alpi

Carmelo1965 Profilo | Junior Member

come solo il log aspetto ti rinvio il tutto altrimenti se hai una e-mail ti invio il zip
Ciao, ringrazio tutti per la vostra pazienza...

alx_81 Profilo | Guru

>come solo il log aspetto ti rinvio il tutto altrimenti se hai una e-mail ti invio il zip
contattami tramite messaggio privato in dotnethell.it, continua ad arrivarmi solo install.log nello zip


--
Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.support.microsoft.com/profile/Alessandro.Alpi

Carmelo1965 Profilo | Junior Member

e come si fa
Ciao, ringrazio tutti per la vostra pazienza...

alx_81 Profilo | Guru

>e come si fa
vai su contattami in questa pagina e scrivimi, poi ci sentiamo via email
http://www.dotnethell.it/users/alx_81.aspx
--
Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.support.microsoft.com/profile/Alessandro.Alpi

Carmelo1965 Profilo | Junior Member

Ciao Alex, ieri sono stato su contatti e ti ho inviato la mia e-mail l'hai ricevuto, quando puoi
fammi sapere come fare per allegare i mie dati,
Saluti Carmelo
Ciao, ringrazio tutti per la vostra pazienza...

alx_81 Profilo | Guru

>Ciao Alex, ieri sono stato su contatti e ti ho inviato la mia
>e-mail l'hai ricevuto, quando puoi
>fammi sapere come fare per allegare i mie dati,
>Saluti Carmelo
Ciao, scusami per il ritardo, ma devo trovare un secondo di tempo per le risposte out of forum

--
Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.support.microsoft.com/profile/Alessandro.Alpi

Carmelo1965 Profilo | Junior Member

Ciao Alex non preocuparti fai con calma non è urgentissimo, quando puoi fammi sapere per il link del datagrid che punta
al cliente che desidero. se risolvo prima ti faccio sapere grazie mille
Ciao, ringrazio tutti per la vostra pazienza...
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2017
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5