Necessario client per Oracle versione 8.1.7 o successiva

lunedì 11 aprile 2011 - 12.02
Tag Elenco Tags  C#  |  .NET 1.1  |  .NET 3.5  |  Windows Server 2008  |  Oracle 10g

volperubbia Profilo | Senior Member

Ciao a tutti,
sto installando due applicazioni web, una 1.1 e l'altra 3.5, su un server
windows server 2008 a 64 bit.
Per entrambe ottengo il seguente errore:

"Per utilizzare System.Data.OracleClient è necessario il software client per Oracle
versione 8.1.7 o successiva."

Qualche idea?

Grazie per l'attenzione,
Davide

freeteo Profilo | Guru

Ciao,
non ho esperienza diretta con Oracle, ma se ti chiede il provider forse vuole questo:
http://www.oracle.com/technetwork/topics/dotnet/index-085163.html

Tu hai sviluppato l'applicazione attaccandoti ad Oracle immagino, quindi probabilmente avevi già installato nella tua macchina una versione di questo pacchetto...

Ciao.

Matteo Raumer
[MCAD .net, MVP Visual C#]
http://blogs.dotnethell.it/freeteo

volperubbia Profilo | Senior Member

Ciao Matteo, grazie.
Era un problema di permessi alle cartelle:
- http://forums.asp.net/t/327841.aspx/1
- http://stackoverflow.com/questions/447983/system-data-oracleclient-requires-oracle-client-software-version-8-1-7.

Alla fine va anche fatto il riavvio del server.

Davide

freeteo Profilo | Guru

>Ciao Matteo, grazie.
>Era un problema di permessi alle cartelle:
grazie a te di aver postato la soluzione.

Ciao.

Matteo Raumer
[MCAD .net, MVP Visual C#]
http://blogs.dotnethell.it/freeteo
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2017
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5