Problema di connessione dopo spostamento del s.o.

lunedì 06 giugno 2011 - 18.31
Tag Elenco Tags  SQL Server 2005  |  SQL Server Express

stefano1856 Profilo | Junior Member

Salve,
ho spostato il s.o. su un disco nuovo per problemi di sapzio.
Ho provato ad eseguire un applicazione che fino a prima dello spostamento funzionava regolarmente in rete.

In locale funziona mentre in rete l'errore è questo anche con ssms:

Si è verificato un errore di rete o specifico dell'istanza mentre si cercava di stabilire una connessione con il server SQL. Il server non è stato trovato o non è accessibile. Verificare che il nome dell'istanza sia corretto e che il server SQL sia configurato in modo da consentire connessioni remote. (provider: Interfacce di rete SQL, error: 26 - Errore nell'individuazione del server/dell'istanza specificata) (Microsoft SQL Server, errore: -1)

ma ho ricontrollato sia le impostazioni delle connesioni remote che del firewall

inoltre ho anche reinstallato sqlserver (versione express)

lbenaglia Profilo | Guru

>Salve,
>ho spostato il s.o. su un disco nuovo per problemi di sapzio.
>Ho provato ad eseguire un applicazione che fino a prima dello
>spostamento funzionava regolarmente in rete.
>
>In locale funziona mentre in rete l'errore è questo anche con
>ssms:
>
>Si è verificato un errore di rete o specifico dell'istanza mentre
>si cercava di stabilire una connessione con il server SQL. Il
>server non è stato trovato o non è accessibile. Verificare che
>il nome dell'istanza sia corretto e che il server SQL sia configurato
>in modo da consentire connessioni remote. (provider: Interfacce
>di rete SQL, error: 26 - Errore nell'individuazione del server/dell'istanza
>specificata) (Microsoft SQL Server, errore: -1)
>
>ma ho ricontrollato sia le impostazioni delle connesioni remote
>che del firewall
>
>inoltre ho anche reinstallato sqlserver (versione express)

Ciao,

Non ho capito bene la situazione.
Applicazione e SQL Server risiedono sul medesimo computer ed è quello dove hai "spostato" l'OS su un nuovo disco (magari spiegaci nel dettaglio cosa hai fatto)?
Se la risposta è affermativa, hai in LAN altri PC con installata l'applicazione e stai cercando di accedere all'istanza sul server che hai "pastrugnato"?

Ciao!

--
Lorenzo Benaglia
Microsoft MVP - SQL Server
http://blogs.dotnethell.it/lorenzo/

stefano1856 Profilo | Junior Member

Ciao,

Si:
Applicazione e SQL Server risiedono sul medesimo computer ed è quello dove ho "spostato" l'OS su un nuovo disco tramite apposito sw di backup e restore.
Sul server tutto funziona.

In LAN gli altri PC con installata l'applicazione non accedono all'istanza sul server "pastrugnato"

lbenaglia Profilo | Guru

>Si:
OK, per rendere raggiungibile l'istanza dall'esterno segui i consigli che trovi in questo thread:
http://www.dotnethell.it/forum/messages.aspx?ThreadID=10971

Ciao!
--
Lorenzo Benaglia
Microsoft MVP - SQL Server
http://blogs.dotnethell.it/lorenzo/

stefano1856 Profilo | Junior Member

Sembra che il problema sia su SQL Browser perchè se sostituisco il nome del server con l'indirizzo IP la connessione avviene , ma il servizio è attivo e la porta UDP relativa è aperta nel firewall

lbenaglia Profilo | Guru

>Sembra che il problema sia su SQL Browser perchè se sostituisco
>il nome del server con l'indirizzo IP la connessione avviene
>, ma il servizio è attivo e la porta UDP relativa è aperta nel
>firewall

Sicuro che non hai problemi di risoluzione DNS?
Oltre alla UDP 1434 devi aprire la porta TCP dinamica che viene restituita al client. Generalmente quando ci sono di mezzo Firewall si imposta una porta TCP statica e si apre solo quella.

Ciao!
--
Lorenzo Benaglia
Microsoft MVP - SQL Server
http://blogs.dotnethell.it/lorenzo/

stefano1856 Profilo | Junior Member

Ho controllato la porta tcp è statica e aperta nel firewall e infatti la connessione via indirizzo ip funziona correttamente.
Se uso il comando sqlcmd -L l'istanza è visibile "nome-pc\istanza" ma se lo metto al posto dell'indirizzo ip nella stringa di connessione la stessa avviene solo in locale mentre in rete da errore ("...server non trovato .. error 26..., ecc")

Per il momentò disattiverò il servizio e userò l'indirizzo ip in attesa di trovare il problema.
Saluti
Stefano

lbenaglia Profilo | Guru

>Per il momentò disattiverò il servizio e userò l'indirizzo ip
>in attesa di trovare il problema.

Ciao Stefano,

Se da un client fai ping nome-pc ottieni una risposta?

Ciao!
--
Lorenzo Benaglia
Microsoft MVP - SQL Server
http://blogs.dotnethell.it/lorenzo/

stefano1856 Profilo | Junior Member

Ciao
in effetti non funziona nemmeno il ping

lbenaglia Profilo | Guru

>in effetti non funziona nemmeno il ping
Se la tua LAN non dispone di un DNS server, verifica nella proprietà della scheda di rete che sia abilitato il NetBIOS over TCP/IP e riprova ad eseguire il ping.

Ciao!
--
Lorenzo Benaglia
Microsoft MVP - SQL Server
http://blogs.dotnethell.it/lorenzo/

stefano1856 Profilo | Junior Member

Ho riscontrato che il problema è dovuto al router , anche esso cambiato di recente.Probabilemte va configurato a tale proposito.
Infatti se collego il router precedente la connessione funziona
Grazie
Ciao
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2017
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5