Connessione SQL Serv. 2005 Express da VS 2008 Express in design time.

giovedì 18 agosto 2011 - 19.37
Tag Elenco Tags  VB.NET  |  .NET 3.5  |  Windows 7  |  Visual Studio 2008  |  SQL Server 2005

franklondon Profilo | Newbie

Ciao a tutti,

Ho creato un DB con SQL Server 2005 Express edition al quale accedo da VS 2008 Express via codice VB e tutto funziona,
quando cerco di utilizzare il wizard in design time non ci riesco in nessun modo.

Cerco di accedervi con lo stesso utente e relativa password ho provato sia con opzione "Windows Authentication" che "SQL Authentication".
Anche se preferirei accedervi con SQL Authentication dato che ho crato l'utente in SQL server per lo scopo.
Nel form del wizard "Add Connection" le ho provate un po' tutte allora inizialmente avevo un problema che ho risolto con il parametro "Integrated security=true" nel senso che era impostato a "false" di default ma andava impostato come "true".
Senza che io imposti nulla il DB viene cercato nella cartella documents e quando provo a settare il path corretto ossia

C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data\db_prova.mdf

mi dice che e' in uso e non puo' essere collegato.
Ho tralasciato un info che non so' se pu' essere utile per aiutarmi, nel form "change datasource" ho scelto "Microsoft SQL Server DataBase File"

"Data Source=.\SQLEXPRESS; AttachDbFilename=C:\Users\Admin\Documents\db_prova.mdf;Integrated Security=True;User ID=prova;Connect Timeout=30;User Instance=True"

DB e WinApplication sono sulla stessa macchina Win 7 32bit Eng.
Una cosa che ho notato e' che quando setto la proprieta' "Integrated security=true" in automatico si setta su "Windows Authentication".

Perdonatemi se ho scritto un poema per dire 3 cavolate.
Spero possiate darmi una dritta

Grazie

Francesco

Cteniza Profilo | Guru

Devi capire che quando utilizzi in rete o da più postazioni NON puoi usare la stessa sintassi che express predispone con il wizard.
Devi passare ad una connessione "vera" (guarda www.connectionstrings.com) e ad una stringa di connessione "normale" dove NON è citato il database ma solo il server se nella stringa di connessione hai il file .mdf la connessione NON è quella giusta.
Dopo aver configurato sql server per le connessioni "come meglio ti pare" (io sceglierei l'autenticazione mista così puoi connetterti in locale e da remoto), poi si passa ad "alzare" i servizi (tcp di sicuro), se hai windows7 devi autorizzare (firewall) il server a prendere comunicazioni dall'esterno.

franklondon Profilo | Newbie

Ti ringrazio innanzitutto per l'attenzione, mi dici tante cose e mi confondi un po' sicuramente poiche' il mio livello di conosenza e' molto basso.
Partiamo da quello che e' il mio obbiettivo vorrei semplicemente fare il databind di alcune combobox in designtime dire questo e' il DB questa e' la tabella e i campi relativi se riuscissi a configurare la connessione tramite wizard tutto sarebbe piu' semplice.
Sono daccordo con te che quella stringa di connessione non ha senso ma quando hai a che fare con il wizard non puoi modificarla manualmente.

Il mio utente su SQL server magagement studio ha il flag su SQL server authentication ma l'altra possibilita' e' windows authentication come faccio ad impostarla mista ricordo con SQL 2000 c'era la voce.

Io vorrei sapere per un utente SQL 2005 express con "SQL Authentication" come devo settare le proprieta' del wizard di VS 2008 express del quale allego la snapshot.
Poiche' credo sia solo un problema di proprieta' della stringa di connessione.


>Devi capire che quando utilizzi in rete o da più postazioni NON
>puoi usare la stessa sintassi che express predispone con il wizard.
>Devi passare ad una connessione "vera" (guarda www.connectionstrings.com)

>e ad una stringa di connessione "normale" dove NON è citato il
>database ma solo il server se nella stringa di connessione hai
>il file .mdf la connessione NON è quella giusta.

Convengo pienamanete con te ma abbiamo a che fare con un wizard e non ci posso fare granche' cio' che riporto e cio' che viene generato automaticamente chiaro che la stringa di connessione la scriverei in modo differente in effetti non ho problemi a collegarmi da codice poiche' la stringa la scrivo io.

>Dopo aver configurato sql server per le connessioni "come meglio
>ti pare" (io sceglierei l'autenticazione mista così puoi connetterti
>in locale e da remoto), poi si passa ad "alzare" i servizi (tcp
>di sicuro), se hai windows7 devi autorizzare (firewall) il server
>a prendere comunicazioni dall'esterno.

Grazie ancora
Francesco
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2017
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5