Test connessione Wireless su Applicazione x Windows CE

martedì 06 settembre 2011 - 11.27
Tag Elenco Tags  VB.NET  |  Visual Studio 2008

Earthquake Profilo | Junior Member

Ciao a tutti.
Ho realizzato un applicazione per Windows Ce (palmare) ma mi sono imbattuto in un problema piuttosto serio.
Spiego brevemente.
Il Terminalino/Palmare ha un indirizzo ip statico.
L'applicazione si collega via wireless ad un database SqlServer. (non SqlServerCe)
Scambio informazioni da e per il database.
Fin qui tutto ok.
Il problema nasce quando per qualche strano motivo cade la connessione wireless.
sulla mia applicazione la variabile "Connessione" non va in stato Broken.
Quindi se eseguo un test risulta ancora attiva. Ovviamente quando provo poi a leggere o a scrivere sul database mi da errore di connessione.
Cercando su google non ho trovato quello che mi interessava perché tutti i test che propongono sono per terminalini che sono connessi con un indirizzo ip dinamico (DHCP).
Esiste qualche routine per testare la connessione wireless su connessioni con indirizzi ip statici?

Grazie in anticipo

nico839 Profilo | Senior Member

ciao,
prova a guardare qui

http://www.dotnethell.it/forum/messages.aspx?ThreadID=39796


Ciao.
Nicolas

http://perledinico.blogspot.com

Earthquake Profilo | Junior Member

Ti ringrazio per la celere risposta.
Provo e ti farò sapere.
Ancora Grazie.

Earthquake Profilo | Junior Member

Ho dato una rapida occhiata ma purtroppo (ovviamente correggimi se sbaglio), nelle prime righe dell'articolo compaiono le seguenti caratteristiche:

Applies to:
Microsoft .NET Compact Framework version 1.0
Microsoft .NET Compact Framework version 2.0
Windows Mobile–based devices

Per la mia app purtroppo uso come sistema operativo di destinazione il Windows CE (purtroppo i terminalini hanno quel sistema operativo e mi sono dovuto adeguare alle circostanze).

Devo provare ugualmente o ci sono soluzioni alternative?

nico839 Profilo | Senior Member

http://www.opennetcf.com/

dice che funziona su windows ce, la libreria dovrebbe andare e con poche modifiche al codice dovrebbe funzionare...
io lo avevo sviluppato per wm 5.0 e 6.0 ma dovrebbe andare anche su ce
Ciao.
Nicolas

http://perledinico.blogspot.com

Earthquake Profilo | Junior Member

Da una prima analisi sembra funzionare.
Grazie per il suggerimento.

nico839 Profilo | Senior Member

prego, non c'è di che
Ciao.
Nicolas

http://perledinico.blogspot.com
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2017
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5