Bocco Record su ACCESS.

mercoledì 10 ottobre 2012 - 12.08
Tag Elenco Tags  Windows 7  |  Windows XP  |  Visual Studio 2010  |  Access (.mdb)  |  Office 2007  |  Office 2003  |  Internet explorer 8.0

Renato1954 Profilo | Newbie

Ciao a tutti, avrei questo problema: ho sviluppato un gestionale in Access e vorrei metterlo in multiutenza, premetto che tutte le tabelle risiedono in un db denominato DATI e posto in condivisione sulla postazione USER_1. Nella postazione USER_1 e USER_2 è posto il gestionale in Access con le tabelle collegate in condivisione. Ora quando entro, ad esempio sul gestionale in USER_2 tutto ok; ma quando entro anche su USER_1 Access va in errore. Eppure il tutto è stato più che condiviso. Se qualcuno può aiutarmi gli/le sarei molto grato, ciao grazie.

alx_81 Profilo | Guru

>Ciao a tutti, avrei questo problema: ho sviluppato un gestionale
>in Access e vorrei metterlo in multiutenza, premetto che tutte
>le tabelle risiedono in un db denominato DATI e posto in condivisione
>sulla postazione USER_1. Nella postazione USER_1 e USER_2 è posto
>il gestionale in Access con le tabelle collegate in condivisione.
>Ora quando entro, ad esempio sul gestionale in USER_2 tutto ok;
>ma quando entro anche su USER_1 Access va in errore. Eppure il
>tutto è stato più che condiviso. Se qualcuno può aiutarmi gli/le
>sarei molto grato, ciao grazie.
Hai provato a controllare nelle opzioni di access che l'open mode sia shared e non esclusivo?
che versione hai?
--
Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.microsoft.com/profiles/Alessandro.Alpi

Renato1954 Profilo | Newbie

Ciao, grazie per avermi risposto. Uso la versione 2003, nel menu strumenti - opzioni mi sembra tutto ok, a meno che mi sfugge qualche cosa ...

alx_81 Profilo | Guru

>Ciao, grazie per avermi risposto. Uso la versione 2003, nel
>menu strumenti - opzioni mi sembra tutto ok, a meno che mi sfugge
>qualche cosa ...
se hai messo quelle opzioni mi viene da dire che dovrebbe andare tutto.
Prova a seguire qui:
http://answers.microsoft.com/en-us/office/forum/office_2003-access/access-2003-setting-up-multiple-users-to-edit/f5213559-aad5-4cca-82d9-7ae84fcd02e6
magari ti è di maggior aiuto

Che errore ricevi di preciso dal secondo che fa accesso?
Ma è sempre la stessa macchina a non riuscire oppure dipende chi si logga per primo?
--
Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.microsoft.com/profiles/Alessandro.Alpi

Renato1954 Profilo | Newbie

Grazie per l'interessamento. Dipende chi logga per primo: indipendente dalla macchina la seconda va in errore con una finestra anonima con scritto Access in errore e dopo due secondi mi butta fuori.

alx_81 Profilo | Guru

>Grazie per l'interessamento. Dipende chi logga per primo:
>indipendente dalla macchina la seconda va in errore con una finestra
>anonima con scritto Access in errore e dopo due secondi mi butta
>fuori.
E' possibile avere quel db? togli pure tutti i dati nella copia..
--
Alessandro Alpi | SQL Server MVP
MCP|MCITP|MCTS|MCT

http://www.alessandroalpi.net
http://blogs.dotnethell.it/suxstellino
http://mvp.microsoft.com/profiles/Alessandro.Alpi

Renato1954 Profilo | Newbie

ciao, ho trovato la soluzione. scusa tanto ma l'errore era molto banale; mettevo si il db dei dati in rete, ma non nella cartella pubblica. ora tutto funziona - ciao e grazie per l'interessamento.
P.S. se posso essere di aiuto ...
Partecipa anche tu! Registrati!
Hai bisogno di aiuto ?
Perchè non ti registri subito?

Dopo esserti registrato potrai chiedere
aiuto sul nostro Forum oppure aiutare gli altri

Consulta le Stanze disponibili.

Registrati ora !
Copyright © dotNetHell.it 2002-2017
Running on Windows Server 2008 R2 Standard, SQL Server 2012 & ASP.NET 3.5